Comprobando el grado de mantenimiento de seguridad de nuestros paquetes con debian-security-support

De todos los paquetes que tienes instalado en tu sistema Debian, seguramente te hayas preguntado cuántos de ellos reciben actualizaciones de seguridad regulares o adecuadas. Muchas son las razones que pueden llevar a que un software determinado no reciba los updates de seguridad necesarios: el mantenedor del paquete no tiene tiempo; paquetes que caen en desuso y dejan de mantenerse activamente; paquetes que pierden al mantenedor activo y no encuentran a un sustituto que se haga cargo de los mismos, etc…

El Proyecto Debian no obstante puede llegar a tomar cartas en el asunto y retirar paquetes que no hayan solventado problemas de seguridad (dependiendo de la gravedad del problema o si lleva mucho tiempo sin solucionarse) como por ejemplo el caso de dotclear o sogo en el update Debian 8.7:

Para comprobar el grado de mantenimiento en materia de seguridad de los paquetes instalados utilizaremos la herramienta debian-security-support. Instalaremos la utilidad desde repositorios:

apt-get install debian-security-support

Posteriormente lanzamos el comando check-support-status para comprobar el estado de cobertura de seguridad de nuestros paquetes:

Como vemos nos muestra una lista de paquetes (binarios) que no son seguros ya que no obtienen actualizaciones de seguridad ni de los autores principales (upstream) ni en repositorios backports adicionales. Tendremos que determinar como administradores en cada caso hasta qué punto podemos prescindir de estos paquetes -si cabe la posibilidad de sustituirlo por otro que cubra la misma funcionalidad mucho mejor- o si por el contrario no queda más remedio que dejarlos instalados. En este último caso, la acción recomendable es utilizar las aplicaciones afectadas sólo en entornos de ejecución segura.